CVE-2018-11806

NameCVE-2018-11806
Descriptionm_cat in slirp/mbuf.c in Qemu has a heap-based buffer overflow via incoming fragmented datagrams.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1781-1, DSA-4454-1
NVD severityhigh (attack range: local)
Debian Bugs901017

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u11fixed
stretch1:2.8+dfsg-6+deb9u5vulnerable
stretch (security)1:2.8+dfsg-6+deb9u8fixed
buster1:3.1+dfsg-8~deb10u1fixed
bullseye, sid1:3.1+dfsg-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:3.1+dfsg-1high901017
qemusourcejessie1:2.1+dfsg-12+deb8u11highDLA-1781-1
qemusourcestretch1:2.8+dfsg-6+deb9u6highDSA-4454-1

Notes

https://lists.gnu.org/archive/html/qemu-devel/2018-06/msg01012.html
https://git.qemu.org/?p=qemu.git;a=commit;h=864036e251f54c99d31df124aad7f34f01f5344c

Search for package or bug name: Reporting problems