CVE-2018-12015

NameCVE-2018-12015
DescriptionIn Perl through 5.26.2, the Archive::Tar module allows remote attackers to bypass a directory-traversal protection mechanism, and overwrite arbitrary files, via an archive file containing a symlink and a regular file with the same name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4226-1
Debian Bugs900834

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)jessie (security), jessie5.20.2-3+deb8u11fixed
stretch5.24.1-3+deb9u2vulnerable
stretch (security)5.24.1-3+deb9u4fixed
buster, sid5.26.2-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
perlsource(unstable)5.26.2-6900834
perlsourcejessie5.20.2-3+deb8u11DSA-4226-1
perlsourcestretch5.24.1-3+deb9u4DSA-4226-1

Notes

https://rt.cpan.org/Public/Bug/Display.html?id=125523
https://github.com/jib/archive-tar-new/commit/ae65651eab053fc6dc4590dbb863a268215c1fc5

Search for package or bug name: Reporting problems