CVE-2018-12085

NameCVE-2018-12085
DescriptionLiblouis 3.6.0 has a stack-based Buffer Overflow in the function parseChars in compileTranslationTable.c, a different vulnerability than CVE-2018-11440.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs901202

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
liblouis (PTS)jessie2.5.3-3+deb8u1vulnerable
stretch3.0.0-3+deb9u4fixed
buster3.8.0-2fixed
bullseye, sid3.10.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
liblouissource(unstable)3.5.0-4medium901202
liblouissourcestretch3.0.0-3+deb9u4medium

Notes

[jessie] - liblouis <no-dsa> (Minor issue)
https://github.com/liblouis/liblouis/issues/595
https://github.com/liblouis/liblouis/commit/dbfa58bb128cae86729578ac596056b3385817ef

Search for package or bug name: Reporting problems