CVE-2018-12122

NameCVE-2018-12122
DescriptionNode.js: All versions prior to Node.js 6.15.0, 8.14.0, 10.14.0 and 11.3.0: Slowloris HTTP Denial of Service: An attacker can cause a Denial of Service (DoS) by sending headers very slowly keeping HTTP or HTTPS connections and associated resources alive for a long period of time.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nodejs (PTS)stretch4.8.2~dfsg-1vulnerable
buster, buster (security)10.24.0~dfsg-1~deb10u1fixed
bullseye (security), bullseye12.22.5~dfsg-2~11u1fixed
bookworm12.22.5~dfsg-5fixed
sid12.22.7~dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nodejssource(unstable)10.15.0~dfsg-6unimportant

Notes

https://nodejs.org/en/blog/vulnerability/november-2018-security-releases/
Nodejs not covered by security support
Patch (v8): https://github.com/nodejs/node/commit/696f063c5e9157fd10859515da00fd8bd190d76d

Search for package or bug name: Reporting problems