CVE-2018-12227

NameCVE-2018-12227
DescriptionAn issue was discovered in Asterisk Open Source 13.x before 13.21.1, 14.x before 14.7.7, and 15.x before 15.4.1 and Certified Asterisk 13.18-cert before 13.18-cert4 and 13.21-cert before 13.21-cert2. When endpoint specific ACL rules block a SIP request, they respond with a 403 forbidden. However, if an endpoint is not identified, then a 401 unauthorized response is sent. This vulnerability just discloses which requests hit a defined endpoint. The ACL rules cannot be bypassed to gain access to the disclosed endpoints.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4320-1
NVD severitymedium
Debian Bugs902954

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)stretch1:13.14.1~dfsg-2+deb9u4fixed
stretch (security)1:13.14.1~dfsg-2+deb9u5fixed
buster1:16.2.1~dfsg-1+deb10u2fixed
bullseye1:16.16.1~dfsg-1fixed
bookworm, sid1:16.16.1~dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksourcejessie(not affected)
asterisksourcestretch1:13.14.1~dfsg-2+deb9u4DSA-4320-1
asterisksource(unstable)1:13.22.0~dfsg-1902954

Notes

[jessie] - asterisk <not-affected> (vulnerable code not present)
http://downloads.asterisk.org/pub/security/AST-2018-008.html
https://issues.asterisk.org/jira/browse/ASTERISK-27818

Search for package or bug name: Reporting problems