CVE-2018-12248

NameCVE-2018-12248
DescriptionAn issue was discovered in mruby 1.4.1. There is a heap-based buffer over-read associated with OP_ENTER because mrbgems/mruby-fiber/src/fiber.c does not extend the stack in cases of many arguments to fiber.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs901653

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mruby (PTS)jessie1.0.0+20141015+gitb4cc962c-1vulnerable
stretch1.2.0+20161228+git30d5424a-1vulnerable
buster, sid1.4.1+20180622+git640fca32-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mrubysource(unstable)1.4.1+20180622+git640fca32-1medium901653

Notes

[stretch] - mruby <no-dsa> (Minor issue)
[jessie] - mruby <no-dsa> (Minor issue)
https://github.com/mruby/mruby/commit/778500563a9f7ceba996937dc886bd8cde29b42b
https://github.com/mruby/mruby/issues/4038

Search for package or bug name: Reporting problems