CVE-2018-12264

NameCVE-2018-12264
DescriptionExiv2 0.26 has integer overflows in LoaderTiff::getData() in preview.cpp, leading to an out-of-bounds read in Exiv2::ValueType::setDataArea in value.hpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1402-1, DSA-4238-1
NVD severitymedium
Debian Bugs901707

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exiv2 (PTS)jessie0.24-4.1vulnerable
jessie (security)0.24-4.1+deb8u5fixed
stretch (security), stretch0.25-3.1+deb9u1fixed
bullseye, sid, buster0.25-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exiv2source(unstable)0.25-4901707
exiv2sourcejessie0.24-4.1+deb8u1DLA-1402-1
exiv2sourcestretch0.25-3.1+deb9u1DSA-4238-1

Notes

https://github.com/Exiv2/exiv2/issues/366
https://github.com/Exiv2/exiv2/commit/fe70939f54476e99046245ca69ff27012401f759

Search for package or bug name: Reporting problems