CVE-2018-12326

NameCVE-2018-12326
DescriptionBuffer overflow in redis-cli of Redis before 4.0.10 and 5.x before 5.0 RC3 allows an attacker to achieve code execution and escalate to higher privileges via a crafted command line. NOTE: It is unclear whether there are any common situations in which redis-cli is used with, for example, a -h (aka hostname) argument from an untrusted source.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1396-1, DSA-4230-1
NVD severitymedium (attack range: local)
Debian Bugs902410

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
redis (PTS)jessie2:2.8.17-1+deb8u5vulnerable
jessie (security)2:2.8.17-1+deb8u6fixed
stretch3:3.2.6-3+deb9u2fixed
stretch (security)3:3.2.6-3+deb9u1fixed
buster, sid5:5.0.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
redissource(unstable)5:4.0.10-1medium902410
redissourcejessie2:2.8.17-1+deb8u6mediumDLA-1396-1
redissourcestretch3:3.2.6-3+deb9u1mediumDSA-4230-1

Notes

https://gist.github.com/fakhrizulkifli/f831f40ec6cde4f744c552503d8698f0
https://github.com/antirez/redis/commit/9fdcc15962f9ff4baebe6fdd947816f43f730d50

Search for package or bug name: Reporting problems