CVE-2018-12364

NameCVE-2018-12364
DescriptionNPAPI plugins, such as Adobe Flash, can send non-simple cross-origin requests, bypassing CORS by making a same-origin POST that does a 307 redirect to the target site. This allows for a malicious site to engage in cross-site request forgery (CSRF) attacks. This vulnerability affects Thunderbird < 60, Thunderbird < 52.9, Firefox ESR < 60.1, Firefox ESR < 52.9, and Firefox < 61.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1406-1, DLA-1425-1, DSA-4235-1, DSA-4244-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid63.0.1-1fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1vulnerable
jessie (security)60.3.0esr-1~deb8u1fixed
stretch (security), stretch60.3.0esr-1~deb9u1fixed
buster, sid60.3.0esr-1fixed
thunderbird (PTS)jessie1:52.8.0-1~deb8u1vulnerable
jessie (security)1:60.3.0-1~deb8u1fixed
stretch1:60.2.1-2~deb9u1fixed
stretch (security)1:60.3.0-1~deb9u1fixed
buster, sid1:60.3.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)61.0-1
firefox-esrsource(unstable)52.9.0esr-1
firefox-esrsourcejessie52.9.0esr-1~deb8u1DLA-1406-1
firefox-esrsourcestretch52.9.0esr-1~deb9u1DSA-4235-1
thunderbirdsource(unstable)1:52.9.0-1
thunderbirdsourcejessie1:52.9.1-1~deb8u1DLA-1425-1
thunderbirdsourcestretch1:52.9.1-1~deb9u1DSA-4244-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2018-15/#CVE-2018-12364
https://www.mozilla.org/en-US/security/advisories/mfsa2018-17/#CVE-2018-12364
https://www.mozilla.org/en-US/security/advisories/mfsa2018-18/#CVE-2018-12364

Search for package or bug name: Reporting problems