CVE-2018-12404

NameCVE-2018-12404
DescriptionA cached side channel attack during handshakes using RSA encryption could allow for the decryption of encrypted content. This is a variant of the Adaptive Chosen Ciphertext attack (AKA Bleichenbacher attack) and affects all NSS versions prior to NSS 3.41.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1704-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nss (PTS)jessie2:3.26-1+debu8u3vulnerable
jessie (security)2:3.26-1+debu8u6fixed
stretch (security), stretch2:3.26.2-1.1+deb9u1vulnerable
buster2:3.42.1-1fixed
bullseye, sid2:3.45-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nsssource(unstable)2:3.41-1medium
nsssourcejessie2:3.26-1+debu8u4mediumDLA-1704-1

Notes

http://cat.eyalro.net/
https://bugzilla.mozilla.org/show_bug.cgi?id=1485864 (not public)
https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.36.6_release_notes
Fixed in 3.36.6, 3.40.1

Search for package or bug name: Reporting problems