CVE-2018-12422

NameCVE-2018-12422
Description** DISPUTED ** addressbook/backends/ldap/e-book-backend-ldap.c in Evolution-Data-Server in GNOME Evolution through 3.29.2 might allow attackers to trigger a Buffer Overflow via a long query that is processed by the strcat function. NOTE: the software maintainer disputes this because "the code had computed the required string length first, and then allocated a large-enough buffer on the heap."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs901665

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
evolution-data-server (PTS)jessie3.12.9~git20141128.5242b0-2+deb8u3vulnerable
jessie (security)3.12.9~git20141128.5242b0-2+deb8u4vulnerable
stretch3.22.7-1vulnerable
buster, sid3.30.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
evolution-data-serversource(unstable)3.28.5-1unimportant901665

Notes

https://bugzilla.gnome.org/show_bug.cgi?id=796174
https://gitlab.gnome.org/GNOME/evolution-data-server/commit/34bad6173
non-issue, to be rejected

Search for package or bug name: Reporting problems