CVE-2018-12438

NameCVE-2018-12438
DescriptionThe Elliptic Curve Cryptography library (aka sunec or libsunec) allows a memory-cache side-channel attack on ECDSA signatures, aka the Return Of the Hidden Number Problem or ROHNP. To discover an ECDSA key, the attacker needs access to either the local machine or a different virtual machine on the same physical host.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openjdk-11 (PTS)buster, sid11.0.1+13-3vulnerable
openjdk-7 (PTS)jessie7u181-2.6.14-1~deb8u1fixed
jessie (security)7u181-2.6.14-2~deb8u1fixed
openjdk-8 (PTS)stretch (security), stretch8u181-b13-2~deb9u1vulnerable
buster8u171-b11-2vulnerable
sid8u191-b12-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjdk-10source(unstable)(unfixed)low
openjdk-11source(unstable)(unfixed)low
openjdk-7source(unstable)(not affected)
openjdk-8source(unstable)(unfixed)low

Notes

- openjdk-7 <not-affected> (Didn't include/build sunec, see #750400)
[stretch] - openjdk-8 <postponed> (Wait until next OpenJDK security release)

Search for package or bug name: Reporting problems