CVE-2018-12545

NameCVE-2018-12545
DescriptionIn Eclipse Jetty version 9.3.x and 9.4.x, the server is vulnerable to Denial of Service conditions if a remote client sends either large SETTINGs frames container containing many settings, or many small SETTINGs frames. The vulnerability is due to the additional CPU and memory allocations required to handle changed settings.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jetty9 (PTS)stretch9.2.21-1+deb9u1fixed
stretch (security)9.2.30-0+deb9u2fixed
buster, buster (security)9.4.16-0+deb10u1fixed
bookworm, bullseye9.4.39-3fixed
sid9.4.44-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jetty9source(unstable)(not affected)

Notes

- jetty9 <not-affected> (Vulnerable code never present in Debian released version)
https://bugs.eclipse.org/bugs/show_bug.cgi?id=538096
Issue is not present in 9.2.x as there is no HTTP/2 support. Fixed upstream
in 9.4.12. Debian package moved directly to 9.4.14-1 containing the fix and
thus never including in unstable a vulnerable version.
Cf. https://bugs.eclipse.org/bugs/show_bug.cgi?id=538096#c7

Search for package or bug name: Reporting problems