CVE-2018-1258

NameCVE-2018-1258
DescriptionSpring Framework version 5.0.5 when used in combination with any versions of Spring Security contains an authorization bypass when using method security. An unauthorized malicious user can gain unauthorized access to methods that should be restricted.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libspring-security-2.0-java (PTS)jessie2.0.7.RELEASE-3fixed
jessie (security)2.0.7.RELEASE-3+deb8u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libspring-security-2.0-javasource(unstable)(unfixed)
libspring-security-2.0-javasourcejessie(not affected)

Notes

[jessie] - libspring-security-2.0-java <not-affected> (Affected version not in jessie)
https://pivotal.io/security/cve-2018-1258

Search for package or bug name: Reporting problems