CVE-2018-12581

NameCVE-2018-12581
DescriptionAn issue was discovered in js/designer/move.js in phpMyAdmin before 4.8.2. A Cross-Site Scripting vulnerability has been found where an attacker can use a crafted database name to trigger an XSS attack when that database is referenced from the Designer feature.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)jessie4:4.2.12-2+deb8u2fixed
jessie (security)4:4.2.12-2+deb8u3fixed
stretch4:4.6.6-4fixed
buster, sid4:4.6.6-5vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsource(unstable)(unfixed)low
phpmyadminsourcejessie(not affected)
phpmyadminsourcestretch(not affected)

Notes

[stretch] - phpmyadmin <not-affected> (Vulnerable code not present)
[jessie] - phpmyadmin <not-affected> (vulnerable code not present)
https://www.phpmyadmin.net/security/PMASA-2018-3/
https://github.com/phpmyadmin/phpmyadmin/commit/6943fff87324bd54c3a37a5160a5fb77498c355e

Search for package or bug name: Reporting problems