CVE-2018-12601

NameCVE-2018-12601
DescriptionThere is a heap-based buffer overflow in ReadImage in input-tga.ci in sam2p 0.49.4 that leads to a denial of service or possibly unspecified other impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1463-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sam2p (PTS)jessie0.49.2-3+deb8u2vulnerable
jessie (security)0.49.2-3+deb8u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sam2psource(unstable)(unfixed)high
sam2psourcejessie0.49.2-3+deb8u3highDLA-1463-1

Notes

https://github.com/pts/sam2p/issues/41
https://github.com/pts/sam2p/commit/8b2b7151991e07ef262857c2325e95c3b2867f80

Search for package or bug name: Reporting problems