CVE-2018-12605

NameCVE-2018-12605
DescriptionAn issue was discovered in GitLab Community Edition and Enterprise Edition 10.7.x before 10.7.6. The usage of 'url_for' contained a XSS issue due to it allowing arbitrary protocols as a parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs902726

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gitlab (PTS)sid/contrib13.4.7-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gitlabsourcestretch(not affected)
gitlabsource(unstable)10.7.7+dfsg-2902726

Notes

[stretch] - gitlab <not-affected> (Only affects 10.7)
https://about.gitlab.com/2018/06/25/security-release-gitlab-11-dot-0-dot-1-released/

Search for package or bug name: Reporting problems