CVE-2018-1301

NameCVE-2018-1301
DescriptionA specially crafted request could have crashed the Apache HTTP Server prior to version 2.4.30, due to an out of bound access after a size limit is reached by reading the HTTP header. This vulnerability is considered very hard if not impossible to trigger in non-debug mode (both log and build level), so it is classified as low risk for common server usage.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1389-1, DSA-4164-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)jessie2.4.10-10+deb8u12fixed
jessie (security)2.4.10-10+deb8u14fixed
stretch, stretch (security)2.4.25-3+deb9u7fixed
buster, sid2.4.38-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.4.33-1medium
apache2sourcejessie2.4.10-10+deb8u12mediumDSA-4164-1
apache2sourcestretch2.4.25-3+deb9u4mediumDSA-4164-1
apache2sourcewheezy2.2.22-13+deb7u13mediumDLA-1389-1

Notes

http://www.openwall.com/lists/oss-security/2018/03/24/2

Search for package or bug name: Reporting problems