CVE-2018-1303

NameCVE-2018-1303
DescriptionA specially crafted HTTP request header could have crashed the Apache HTTP Server prior to version 2.4.30 due to an out of bound read while preparing data to be cached in shared memory. It could be used as a Denial of Service attack against users of mod_cache_socache. The vulnerability is considered as low risk since mod_cache_socache is not widely used, mod_cache_disk is not concerned by this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4164-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)jessie2.4.10-10+deb8u12fixed
jessie (security)2.4.10-10+deb8u14fixed
stretch (security), stretch2.4.25-3+deb9u7fixed
bullseye, sid, buster2.4.38-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.4.33-1medium
apache2sourcejessie2.4.10-10+deb8u12mediumDSA-4164-1
apache2sourcestretch2.4.25-3+deb9u4mediumDSA-4164-1
apache2sourcewheezy(not affected)

Notes

[wheezy] - apache2 <not-affected> (Vulnerable code not present)
http://www.openwall.com/lists/oss-security/2018/03/24/3

Search for package or bug name: Reporting problems