CVE-2018-13043

NameCVE-2018-13043
Descriptionscripts/grep-excuses.pl in Debian devscripts through 2.18.3 allows code execution through unsafe YAML loading because YAML::Syck is used without a configuration that prevents unintended blessing.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs902409

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
devscripts (PTS)jessie (security), jessie2.15.3+deb8u1fixed
stretch2.17.6+deb9u2fixed
buster, sid2.18.9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
devscriptssource(unstable)2.18.4low902409
devscriptssourcejessie(not affected)
devscriptssourcestretch(not affected)

Notes

[stretch] - devscripts <not-affected> (Vulnerable code introduced in 2.17.7)
[jessie] - devscripts <not-affected> (Vulnerable code introduced in 2.17.7)

Search for package or bug name: Reporting problems