CVE-2018-13304

NameCVE-2018-13304
DescriptionIn libavcodec in FFmpeg 4.0.1, improper maintenance of the consistency between the context profile field and studio_profile in libavcodec may trigger an assertion failure while converting a crafted AVI file to MPEG4, leading to a denial of service, related to error_resilience.c, h263dec.c, and mpeg4videodec.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)buster7:4.1.9-0+deb10u1fixed
buster (security)7:4.1.10-0+deb10u1fixed
bullseye (security), bullseye7:4.3.5-0+deb11u1fixed
bookworm, sid7:5.1.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsourcestretch(not affected)
ffmpegsource(unstable)7:4.0.2-1
libavsourcejessie(not affected)
libavsource(unstable)(unfixed)

Notes

[stretch] - ffmpeg <not-affected> (Vulnerable code not present)
[jessie] - libav <not-affected> (vulnerable code is not present)
https://github.com/FFmpeg/FFmpeg/commit/bd27a9364ca274ca97f1df6d984e88a0700fb235

Search for package or bug name: Reporting problems