CVE-2018-13873

NameCVE-2018-13873
DescriptionAn issue was discovered in the HDF HDF5 1.8.20 library. There is a buffer over-read in H5O_chunk_deserialize in H5Ocache.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hdf5 (PTS)jessie (security), jessie1.8.13+docs-15+deb8u1undetermined
stretch1.10.0-patch1+docs-3+deb9u1undetermined
buster1.10.4+repack-1undetermined
sid1.10.4+repack-2undetermined

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hdf5source(unstable)undeterminedhigh

Notes

https://github.com/TeamSeri0us/pocs/tree/master/hdf5

Search for package or bug name: Reporting problems