CVE-2018-14055

NameCVE-2018-14055
DescriptionZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing a non-admin user to escalate his privilege and inject rogue values into znc.conf.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1427-1, DSA-4252-1
NVD severitymedium (attack range: remote)
Debian Bugs903787

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
znc (PTS)jessie1.4-2vulnerable
jessie (security)1.4-2+deb8u1fixed
stretch (security), stretch1.6.5-1+deb9u1fixed
buster, sid1.7.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zncsource(unstable)1.7.1-1medium903787
zncsourcejessie1.4-2+deb8u1mediumDLA-1427-1
zncsourcestretch1.6.5-1+deb9u1mediumDSA-4252-1

Notes

https://github.com/znc/znc/commit/a7bfbd93812950b7444841431e8e297e62cb524e
https://github.com/znc/znc/commit/d22fef8620cdd87490754f607e7153979731c69d
http://www.openwall.com/lists/oss-security/2018/07/18/4

Search for package or bug name: Reporting problems