CVE-2018-14341

NameCVE-2018-14341
DescriptionIn Wireshark 2.6.0 to 2.6.1, 2.4.0 to 2.4.7, and 2.2.0 to 2.2.15, the DICOM dissector could go into a large or infinite loop. This was addressed in epan/dissectors/packet-dcm.c by preventing an offset overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1451-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)jessie1.12.1+g01b65bf-4+deb8u14vulnerable
jessie (security)1.12.1+g01b65bf-4+deb8u15fixed
stretch (security), stretch2.6.3-1~deb9u1fixed
buster, sid2.6.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)2.6.2-1high
wiresharksourcejessie1.12.1+g01b65bf-4+deb8u15highDLA-1451-1

Notes

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14742
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=2e716c32be6aa20e1813b0002878853e71f8b2f4
https://www.wireshark.org/security/wnpa-sec-2018-39.html

Search for package or bug name: Reporting problems