CVE-2018-14346

NameCVE-2018-14346
DescriptionGNU Libextractor before 1.7 has a stack-based buffer overflow in ec_read_file_func (unzip.c).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1478-1, DSA-4290-1
NVD severitymedium (attack range: remote)
Debian Bugs904903

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libextractor (PTS)jessie1:1.3-2+deb8u1vulnerable
jessie (security)1:1.3-2+deb8u3fixed
stretch1:1.3-4+deb9u1vulnerable
stretch (security)1:1.3-4+deb9u2fixed
sid1:1.6-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libextractorsource(unstable)(unfixed)medium904903
libextractorsourcejessie1:1.3-2+deb8u2mediumDLA-1478-1
libextractorsourcestretch1:1.3-4+deb9u2mediumDSA-4290-1

Notes

http://lists.gnu.org/archive/html/bug-libextractor/2018-07/msg00001.html
https://gnunet.org/git/libextractor.git/commit/?id=ad19e7fe0adc99d5710eff1ed48d91a7b75a950e

Search for package or bug name: Reporting problems