CVE-2018-14347

NameCVE-2018-14347
DescriptionGNU Libextractor before 1.7 contains an infinite loop vulnerability in EXTRACTOR_mpeg_extract_method (mpeg_extractor.c).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1478-1, DSA-4290-1
Debian Bugs904905

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libextractor (PTS)buster1:1.8-2+deb10u1fixed
bullseye1:1.11-2fixed
bookworm, sid1:1.11-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libextractorsourcejessie1:1.3-2+deb8u2DLA-1478-1
libextractorsourcestretch1:1.3-4+deb9u2DSA-4290-1
libextractorsource(unstable)1:1.7-1904905

Notes

http://lists.gnu.org/archive/html/bug-libextractor/2018-07/msg00000.html
https://gnunet.org/bugs/view.php?id=5399
https://git.gnunet.org/libextractor.git/commit/?id=f033468cd36e2b8bf92d747fbd683b2ace8da394

Search for package or bug name: Reporting problems