CVE-2018-14359

NameCVE-2018-14359
DescriptionAn issue was discovered in Mutt before 1.10.1 and NeoMutt before 2018-07-16. They have a buffer overflow via base64 data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1455-1, DSA-4277-1
NVD severityhigh
Debian Bugs904021, 904051

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mutt (PTS)jessie1.5.23-3vulnerable
jessie (security)1.5.23-3+deb8u1fixed
stretch (security), stretch1.7.2-1+deb9u1fixed
buster1.10.1-2.1fixed
bullseye, sid1.14.0-1fixed
neomutt (PTS)buster20180716+dfsg.1-1fixed
sid20191207+dfsg.1-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
muttsource(unstable)1.10.1-1904051
muttsourcejessie1.5.23-3+deb8u1DLA-1455-1
muttsourcestretch1.7.2-1+deb9u1DSA-4277-1
neomuttsource(unstable)20180716+dfsg.1-1904021

Notes

https://github.com/neomutt/neomutt/commit/6f163e07ae68654d7ac5268cbb7565f6df79ad85
https://gitlab.com/muttmua/mutt/commit/3d9028fec8f4d08db2251096307c0bbbebce669a

Search for package or bug name: Reporting problems