CVE-2018-14403

NameCVE-2018-14403
DescriptionMP4NameFirstMatches in mp4util.cpp in MP4v2 2.0.0 mishandles substrings of atom names, leading to use of an inappropriate data type for associated atoms. The resulting type confusion can cause out-of-bounds memory access.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs904897

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mp4v2 (PTS)jessie2.0.0~dfsg0-3vulnerable
stretch2.0.0~dfsg0-5vulnerable
buster, sid2.0.0~dfsg0-6vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mp4v2source(unstable)(unfixed)high904897

Notes

[stretch] - mp4v2 <no-dsa> (Minor issue)
[jessie] - mp4v2 <no-dsa> (Minor issue)
http://www.openwall.com/lists/oss-security/2018/07/18/3

Search for package or bug name: Reporting problems