CVE-2018-14404

NameCVE-2018-14404
DescriptionA NULL pointer dereference vulnerability exists in the xpath.c:xmlXPathCompOpEval() function of libxml2 through 2.9.8 when parsing an invalid XPath expression in the XPATH_OP_AND or XPATH_OP_OR case. Applications processing untrusted XSL format inputs with the use of the libxml2 library may be vulnerable to a denial of service attack due to a crash of the application.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1524-1
NVD severitymedium (attack range: remote)
Debian Bugs901817

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)jessie2.9.1+dfsg1-5+deb8u6vulnerable
jessie (security)2.9.1+dfsg1-5+deb8u7fixed
stretch (security), stretch2.9.4+dfsg1-2.2+deb9u2vulnerable
buster, sid2.9.4+dfsg1-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)(unfixed)medium901817
libxml2sourcejessie2.9.1+dfsg1-5+deb8u7mediumDLA-1524-1

Notes

[stretch] - libxml2 <no-dsa> (Minor issue)
https://gitlab.gnome.org/GNOME/libxml2/issues/5
https://gitlab.gnome.org/GNOME/libxml2/issues/10
https://gitlab.gnome.org/GNOME/libxml2/commit/a436374994c47b12d5de1b8b1d191a098fa23594

Search for package or bug name: Reporting problems