CVE-2018-14432

NameCVE-2018-14432
DescriptionIn the Federation component of OpenStack Keystone before 11.0.4, 12.0.0, and 13.0.0, an authenticated "GET /v3/OS-FEDERATION/projects" request may bypass intended access restrictions on listing projects. An authenticated user may discover projects they have no authority to access, leaking all projects in the deployment and their attributes. Only Keystone with the /v3/OS-FEDERATION endpoint enabled via policy.json is affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4275-1
NVD severitylow (attack range: remote)
Debian Bugs904616

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
keystone (PTS)jessie2014.1.3-6vulnerable
stretch (security), stretch2:10.0.0-9+deb9u1fixed
buster, sid2:14.0.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
keystonesource(unstable)2:13.0.0-7low904616
keystonesourcejessie(unfixed)end-of-life
keystonesourcestretch2:10.0.0-9+deb9u1lowDSA-4275-1

Notes

[jessie] - keystone <end-of-life> (Not supported in Jessie)
http://www.openwall.com/lists/oss-security/2018/07/25/2
https://bugs.launchpad.net/keystone/+bug/1779205

Search for package or bug name: Reporting problems