CVE-2018-14446

NameCVE-2018-14446
DescriptionMP4Integer32Property::Read in atom_avcC.cpp in MP4v2 2.1.0 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted MP4 file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs904896

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mp4v2 (PTS)jessie2.0.0~dfsg0-3vulnerable
stretch2.0.0~dfsg0-5vulnerable
buster, sid2.0.0~dfsg0-6vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mp4v2source(unstable)(unfixed)medium904896

Notes

[stretch] - mp4v2 <no-dsa> (Minor issue)
[jessie] - mp4v2 <no-dsa> (Minor issue)
https://github.com/TechSmith/mp4v2/issues/20

Search for package or bug name: Reporting problems