CVE-2018-14624

NameCVE-2018-14624
DescriptionA vulnerability was discovered in 389-ds-base through versions 1.3.7.10, 1.3.8.8 and 1.4.0.16. The lock controlling the error log was not correctly used when re-opening the log file in log__error_emergency(). An attacker could send a flood of modifications to a very large DN, which would cause slapd to crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1526-1
NVD severitymedium (attack range: remote)
Debian Bugs907778

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
389-ds-base (PTS)jessie1.3.3.5-4vulnerable
jessie (security)1.3.3.5-4+deb8u5fixed
stretch1.3.5.17-2vulnerable
sid1.4.0.19-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
389-ds-basesource(unstable)1.4.0.18-1medium907778
389-ds-basesourcejessie1.3.3.5-4+deb8u3mediumDLA-1526-1

Notes

https://pagure.io/389-ds-base/issue/49937
https://pagure.io/389-ds-base/c/8ff8cb850 (master)
https://pagure.io/389-ds-base/c/c5e78249d (389-ds-base-1.3.8)
https://pagure.io/389-ds-base/c/9f28620d2 (389-ds-base-1.3.7)

Search for package or bug name: Reporting problems