CVE-2018-14626

NameCVE-2018-14626
DescriptionPowerDNS Authoritative Server 4.1.0 up to 4.1.4 inclusive and PowerDNS Recursor 4.0.0 up to 4.1.4 inclusive are vulnerable to a packet cache pollution via crafted query that can lead to denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs913162, 913163

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns (PTS)jessie3.4.1-4+deb8u8fixed
jessie (security)3.4.1-4+deb8u7fixed
stretch4.0.3-1+deb9u3fixed
buster, sid4.1.6-1fixed
pdns-recursor (PTS)jessie3.6.2-2+deb8u4fixed
jessie (security)3.6.2-2+deb8u3fixed
stretch4.0.4-1+deb9u4fixed
stretch (security)4.0.4-1+deb9u3vulnerable
buster, sid4.1.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdnssource(unstable)4.1.5-1medium913163
pdnssourcejessie(not affected)
pdnssourcestretch(not affected)
pdns-recursorsource(unstable)4.1.7-1medium913162
pdns-recursorsourcejessie(not affected)
pdns-recursorsourcestretch4.0.4-1+deb9u4medium

Notes

[stretch] - pdns <not-affected> (Vulnerable code present only in >=  4.1.0)
[jessie] - pdns <not-affected> (Vulnerable code not present)
[jessie] - pdns-recursor <not-affected> (Vulnerable code not present)
https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2018-05.html
https://downloads.powerdns.com/patches/2018-05/
https://doc.powerdns.com/recursor/security-advisories/powerdns-advisory-2018-06.html
https://downloads.powerdns.com/patches/2018-06/

Search for package or bug name: Reporting problems