DescriptionPowerDNS Authoritative Server 4.1.0 up to 4.1.4 inclusive and PowerDNS Recursor 4.0.0 up to 4.1.4 inclusive are vulnerable to a packet cache pollution via crafted query that can lead to denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs913162, 913163

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns (PTS)jessie3.4.1-4+deb8u8fixed
jessie (security)3.4.1-4+deb8u7fixed
buster, sid4.1.5-1fixed
pdns-recursor (PTS)jessie3.6.2-2+deb8u4fixed
jessie (security)3.6.2-2+deb8u3fixed
stretch (security), stretch4.0.4-1+deb9u3vulnerable
buster, sid4.1.8-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdnssourcejessie(not affected)
pdnssourcestretch(not affected)
pdns-recursorsourcejessie(not affected)


[stretch] - pdns <not-affected> (Vulnerable code present only in >=  4.1.0)
[jessie] - pdns <not-affected> (Vulnerable code not present)
[stretch] - pdns-recursor <no-dsa> (Minor issue)
[jessie] - pdns-recursor <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems