CVE-2018-14629

NameCVE-2018-14629
DescriptionA denial of service vulnerability was discovered in Samba's LDAP server before versions 4.7.12, 4.8.7, and 4.9.3. A CNAME loop could lead to infinite recursion in the server. An unprivileged local attacker could create such an entry, leading to denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1607-1, DSA-4345-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)jessie2:4.2.14+dfsg-0+deb8u9vulnerable
jessie (security)2:4.2.14+dfsg-0+deb8u11fixed
stretch2:4.5.12+dfsg-2+deb9u3vulnerable
stretch (security)2:4.5.12+dfsg-2+deb9u4fixed
buster, sid2:4.9.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.9.2+dfsg-2
sambasourcejessie2:4.2.14+dfsg-0+deb8u11DLA-1607-1
sambasourcestretch2:4.5.12+dfsg-2+deb9u4DSA-4345-1

Notes

https://www.samba.org/samba/security/CVE-2018-14629.html

Search for package or bug name: Reporting problems