CVE-2018-14638

NameCVE-2018-14638
DescriptionA flaw was found in 389-ds-base before version 1.3.8.4-13. The process ns-slapd crashes in delete_passwdPolicy function when persistent search connections are terminated unexpectedly leading to remote denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs908859

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
389-ds-base (PTS)jessie1.3.3.5-4fixed
jessie (security)1.3.3.5-4+deb8u6fixed
stretch1.3.5.17-2vulnerable
buster1.4.0.21-1fixed
bullseye, sid1.4.1.6-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
389-ds-basesource(unstable)1.4.0.18-1908859
389-ds-basesourcejessie(not affected)

Notes

[jessie] - 389-ds-base <not-affected> (Vulnerable code not present)
https://pagure.io/389-ds-base/c/78fc627accacfa4061ce48977e22301f81ea8d73

Search for package or bug name: Reporting problems