CVE-2018-14659

NameCVE-2018-14659
DescriptionThe Gluster file system through versions 4.1.4 and 3.1.2 is vulnerable to a denial of service attack via use of the 'GF_XATTR_IOSTATS_DUMP_KEY' xattr. A remote, authenticated attacker could exploit this by mounting a Gluster volume and repeatedly calling 'setxattr(2)' to trigger a state dump and create an arbitrary number of files in the server's runtime directory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1565-1
NVD severitymedium (attack range: remote)
Debian Bugs912997

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glusterfs (PTS)jessie3.5.2-2+deb8u3vulnerable
jessie (security)3.5.2-2+deb8u5fixed
stretch3.8.8-1vulnerable
buster, sid5.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glusterfssource(unstable)5.1-1medium912997
glusterfssourcejessie3.5.2-2+deb8u5mediumDLA-1565-1

Notes

https://www.openwall.com/lists/oss-security/2018/10/31/5
https://bugzilla.redhat.com/show_bug.cgi?id=1635929
https://review.gluster.org/#/c/glusterfs/+/21530/
http://git.gluster.org/cgit/glusterfs.git/commit/?id=be1e1785e2e4f3d6345ea5b5b684a1429784a01c

Search for package or bug name: Reporting problems