Descriptionlibpango in Pango 1.40.8 through 1.42.3, as used in hexchat and other products, allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via crafted text with invalid Unicode sequences.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pango1.0 (PTS)stretch1.40.5-1fixed
buster (security)1.42.4-7~deb10u1fixed
bullseye, sid1.46.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pango1.0sourcejessie(not affected)
pango1.0sourcestretch(not affected)


[stretch] - pango1.0 <not-affected> (Vulnerable code not present)
[jessie] - pango1.0 <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems