CVE-2018-15209

NameCVE-2018-15209
DescriptionChopUpSingleUncompressedStrip in tif_dirread.c in LibTIFF 4.0.9 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted TIFF file, as demonstrated by tiff2pdf.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs905798

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)jessie4.0.3-12.3+deb8u5fixed
jessie (security)4.0.3-12.3+deb8u6fixed
stretch (security), stretch4.0.8-2+deb9u2vulnerable
buster, sid4.0.9-6vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)(unfixed)905798
tiffsourcejessie(not affected)
tiff3source(unstable)(unfixed)

Notes

[stretch] - tiff <postponed> (Can be fixed along in future DSA)
[jessie] - tiff <not-affected> (Cannot reproduce with crash file)
http://bugzilla.maptools.org/show_bug.cgi?id=2808
The fix for CVE-2017-11613 is possibly covering the bug.

Search for package or bug name: Reporting problems