CVE-2018-15473

NameCVE-2018-15473
DescriptionOpenSSH through 7.7 is prone to a user enumeration vulnerability due to not delaying bailout for an invalid authenticating user until after the packet containing the request has been fully parsed, related to auth2-gss.c, auth2-hostbased.c, and auth2-pubkey.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1474-1, DSA-4280-1
NVD severitymedium (attack range: remote)
Debian Bugs906236

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssh (PTS)jessie1:6.7p1-5+deb8u4vulnerable
jessie (security)1:6.7p1-5+deb8u7fixed
stretch (security), stretch1:7.4p1-10+deb9u4fixed
buster, sid1:7.9p1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensshsource(unstable)1:7.7p1-4medium906236
opensshsourcejessie1:6.7p1-5+deb8u5mediumDLA-1474-1
opensshsourcestretch1:7.4p1-10+deb9u4mediumDSA-4280-1

Notes

http://www.openwall.com/lists/oss-security/2018/08/15/5
https://anongit.mindrot.org/openssh.git/commit/?id=74287f5df9966a0648b4a68417451dd18f079ab8
https://github.com/openbsd/src/commit/779974d35b4859c07bc3cb8a12c74b43b0a7d1e0
PoC at https://bugfuzz.com/stuff/ssh-check-username.py

Search for package or bug name: Reporting problems