CVE-2018-15501

NameCVE-2018-15501
DescriptionIn ng_pkt in transports/smart_pkt.c in libgit2 before 0.26.6 and 0.27.x before 0.27.4, a remote attacker can send a crafted smart-protocol "ng" packet that lacks a '\0' byte to trigger an out-of-bounds read that leads to DoS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1477-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgit2 (PTS)stretch0.25.1+really0.24.6-1vulnerable
buster0.27.7+dfsg.1-0.2fixed
bullseye1.1.0+dfsg.1-4fixed
bookworm, sid1.1.0+dfsg.1-4.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgit2sourcejessie0.21.1-3+deb8u1DLA-1477-1
libgit2source(unstable)0.27.4+dfsg.1-0.1low

Notes

[stretch] - libgit2 <no-dsa> (Minor issue)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9406
https://github.com/libgit2/libgit2/commit/1f9a8510e1d2f20ed7334eeeddb92c4dd8e7c649

Search for package or bug name: Reporting problems