CVE-2018-15687

NameCVE-2018-15687
DescriptionA race condition in chown_one() of systemd allows an attacker to cause systemd to set arbitrary permissions on arbitrary files. Affected releases are systemd versions up to and including 239.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs912007

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
systemd (PTS)jessie215-17+deb8u7fixed
jessie (security)215-17+deb8u8fixed
stretch232-25+deb9u6fixed
buster239-13fixed
sid239-15fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
systemdsource(unstable)239-11912007
systemdsourcejessie(not affected)
systemdsourcestretch(not affected)

Notes

[stretch] - systemd <not-affected> (Vulnerable code introduced later in v235)
[jessie] - systemd <not-affected> (Vulnerable code introduced later in v235)
https://bugs.chromium.org/p/project-zero/issues/detail?id=1689
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1796692
https://github.com/systemd/systemd/pull/10517

Search for package or bug name: Reporting problems