CVE-2018-15751

NameCVE-2018-15751
DescriptionSaltStack Salt before 2017.7.8 and 2018.3.x before 2018.3.3 allow remote attackers to bypass authentication and execute arbitrary commands via salt-api(netapi).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2294-1
Debian Bugs913475

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
salt (PTS)buster, buster (security)2018.3.4+dfsg1-6+deb10u3fixed
bullseye (security), bullseye3002.6+dfsg1-4+deb11u1fixed
sid3004.1+dfsg-2.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
saltsourcejessie(not affected)
saltsourcestretch2016.11.2+ds-1+deb9u5DLA-2294-1
saltsource(unstable)2018.3.3+dfsg1-1913475

Notes

[jessie] - salt <not-affected> (REST netapi code was first introduced with v2014.7)
Fixed in 2016.11.10, 2017.7.8, 2018.3.3
https://docs.saltstack.com/en/latest/topics/releases/2016.11.10.html#security-fix
minimal patch: https://github.com/saltstack/salt/compare/v2016.11.9..v2016.11.10

Search for package or bug name: Reporting problems