CVE-2018-15910

NameCVE-2018-15910
DescriptionIn Artifex Ghostscript before 9.24, attackers able to supply crafted PostScript files could use a type confusion in the LockDistillerParams parameter to crash the interpreter or execute code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1504-1, DSA-4288-1
NVD severitymedium (attack range: remote)
Debian Bugs907332

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)jessie9.06~dfsg-2+deb8u7vulnerable
jessie (security)9.26a~dfsg-0+deb8u1fixed
stretch (security), stretch9.26a~dfsg-0+deb9u1fixed
buster, sid9.26a~dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.22~dfsg-3medium907332
ghostscriptsourcejessie9.06~dfsg-2+deb8u8mediumDLA-1504-1
ghostscriptsourcestretch9.20~dfsg-3.2+deb9u4mediumDSA-4288-1

Notes

http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=c3476dde7743761a4e1d39a631716199b696b880
https://bugs.ghostscript.com/show_bug.cgi?id=699656
https://www.kb.cert.org/vuls/id/332928

Search for package or bug name: Reporting problems