CVE-2018-16140

NameCVE-2018-16140
DescriptionA buffer underwrite vulnerability in get_line() (read.c) in fig2dev 3.2.7a allows an attacker to write prior to the beginning of the buffer via a crafted .fig file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2073-1
NVD severitymedium
Debian Bugs907660

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fig2dev (PTS)stretch1:3.2.6a-2+deb9u3vulnerable
stretch (security)1:3.2.6a-2+deb9u4vulnerable
buster1:3.2.7a-5+deb10u4fixed
bullseye1:3.2.8-3fixed
bookworm, sid1:3.2.8b-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fig2devsource(unstable)1:3.2.7a-3unimportant907660
transfigsourcejessie1:3.2.5.e-4+deb8u2DLA-2073-1
transfigsource(unstable)(unfixed)unimportant

Notes

https://sourceforge.net/p/mcj/tickets/28/
https://sourceforge.net/p/mcj/fig2dev/ci/e0c4b02429116b15ad1568c2c425f06b95b95830
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems