CVE-2018-16151

NameCVE-2018-16151
DescriptionIn verify_emsa_pkcs1_signature() in gmp_rsa_public_key.c in the gmp plugin in strongSwan 4.x and 5.x before 5.7.0, the RSA implementation based on GMP does not reject excess data after the encoded algorithm OID during PKCS#1 v1.5 signature verification. Similar to the flaw in the same version of strongSwan regarding digestAlgorithm.parameters, a remote attacker can forge signatures when small public exponents are being used, which could lead to impersonation when only an RSA signature is used for IKEv2 authentication.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1522-1, DSA-4305-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)jessie5.2.1-6+deb8u6vulnerable
jessie (security)5.2.1-6+deb8u8fixed
stretch5.5.1-4+deb9u2vulnerable
stretch (security)5.5.1-4+deb9u4fixed
buster5.6.3-1vulnerable
sid5.7.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansource(unstable)5.7.0-1
strongswansourcejessie5.2.1-6+deb8u7DLA-1522-1
strongswansourcestretch5.5.1-4+deb9u3DSA-4305-1

Notes

https://strongswan.org/blog/2018/09/24/strongswan-vulnerability-(cve-2018-16151,-cve-2018-16152).html

Search for package or bug name: Reporting problems