CVE-2018-16228

NameCVE-2018-16228
DescriptionThe HNCP parser in tcpdump before 4.9.3 has a buffer over-read in print-hncp.c:print_prefix().
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1955-1, DSA-4547-1
Debian Bugs941698

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpdump (PTS)buster4.9.3-1~deb10u2fixed
buster (security)4.9.3-1~deb10u1fixed
bullseye4.99.0-2+deb11u1fixed
bookworm4.99.3-1fixed
sid, trixie4.99.4-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpdumpsourcejessie4.9.3-1~deb8u1DLA-1955-1
tcpdumpsourcestretch4.9.3-1~deb9u1DSA-4547-1
tcpdumpsourcebuster4.9.3-1~deb10u1DSA-4547-1
tcpdumpsource(unstable)4.9.3-1941698

Notes

https://github.com/the-tcpdump-group/tcpdump/commit/83a412a5275cac973c5841eca3511c766bed778d

Search for package or bug name: Reporting problems