CVE-2018-16230

NameCVE-2018-16230
DescriptionThe BGP parser in tcpdump before 4.9.3 has a buffer over-read in print-bgp.c:bgp_attr_print() (MP_REACH_NLRI).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1955-1
NVD severityhigh (attack range: remote)
Debian Bugs941698

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpdump (PTS)jessie4.9.2-1~deb8u1vulnerable
jessie (security)4.9.3-1~deb8u1fixed
stretch, stretch (security)4.9.2-1~deb9u1vulnerable
buster4.9.2-3vulnerable
bullseye, sid4.9.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpdumpsource(unstable)4.9.3-1high941698
tcpdumpsourcejessie4.9.3-1~deb8u1highDLA-1955-1

Notes

https://github.com/the-tcpdump-group/tcpdump/commit/13d52e9c0e7caf7e6325b0051bc90a49968be67f

Search for package or bug name: Reporting problems