CVE-2018-16301

NameCVE-2018-16301
Descriptionlibpcap before 1.9.1, as used in tcpdump before 4.9.3, has a buffer overflow and/or over-read because of errors in pcapng reading.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs941697

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libpcap (PTS)jessie1.6.2-2fixed
stretch1.8.1-3fixed
buster1.8.1-6fixed
bullseye, sid1.9.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libpcapsource(unstable)1.9.1-1unimportant941697
libpcapsourcebuster(not affected)
libpcapsourcejessie(not affected)
libpcapsourcestretch(not affected)

Notes

[buster] - libpcap <not-affected> (Vulnerable code introduced in 1.9.0)
[stretch] - libpcap <not-affected> (Vulnerable code introduced in 1.9.0)
[jessie] - libpcap <not-affected> (Vulnerable code introduced in 1.9.0)
https://github.com/the-tcpdump-group/libpcap/issues/855 (asked upstream for info)
rpcapd not built in Debian.

Search for package or bug name: Reporting problems