CVE-2018-16419

NameCVE-2018-16419
DescriptionSeveral buffer overflows when handling responses from a Cryptoflex card in read_public_key in tools/cryptoflex-tool.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of service (application crash) or possibly have unspecified other impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)
Debian Bugs909444

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opensc (PTS)jessie0.14.0-2vulnerable
stretch0.16.0-3+deb9u1fixed
buster0.19.0-1fixed
sid0.19.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openscsource(unstable)0.19.0~rc1-1low909444
openscsourcestretch0.16.0-3+deb9u1medium

Notes

[jessie] - opensc <no-dsa> (Minor issue)
https://github.com/OpenSC/OpenSC/commit/360e95d45ac4123255a4c796db96337f332160ad#diff-a6074523a9cbd875e26c58e20868fb15
https://www.x41-dsec.de/lab/advisories/x41-2018-002-OpenSC/

Search for package or bug name: Reporting problems