CVE-2018-16438

NameCVE-2018-16438
DescriptionAn issue was discovered in the HDF HDF5 1.8.20 library. There is an out of bounds read in H5L_extern_query at H5Lexternal.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hdf5 (PTS)stretch1.10.0-patch1+docs-3+deb9u1vulnerable
buster1.10.4+repack-10vulnerable
bullseye1.10.6+repack-4+deb11u1vulnerable
bookworm, sid1.10.7+repack-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hdf5source(unstable)(unfixed)unimportant

Notes

H5L_extern_query@H5Lexternal.c:498-10___out-of-bounds-read
Negligible security impact

Search for package or bug name: Reporting problems